适当减少手机使用,有助于视力保护... 新的一年祝您:身体健康,阖家欢乐!~~

flask_apscheduler 一直报 PytzUsageWarning

浏览量:817 作者:admin 类别:: 学习小记 更新时间:2023-05-04 00:26:24

PytzUsageWarning: The localize method is no longer necessary, as this time zone supports the fold attribute (PEP 495). For more details on migrating to a PEP 495-compliant implementation, see https://pytz-deprecation-shim.readthedocs.io/en/latest/migration.html
  return tzinfo.localize(dt)

 

疑似编码问题,又不像 ,有时候会报有时候不报

后来发现,添加了定时(cron )任务,就会报。。。与编码无关

网上搜了下,什么设置时区的方式,一点用没有。

通过降级 tzlocal 来解决,降到3.0的时候,提示下面的错误。可以发现,

 Requirement.parse('tzlocal!=3.*,>=2.0')

这时,把版本降到2.0 或2.1,就没有报这个错误了。

虽然,不降级也能正常执行任务,只是报这个警告,看着有点不舒服....

 

 

借用老师思路--------------------


问题是pytz被认为已弃用,取而代之的是zoneinfo模块及其后端口。问题是pytz被认为已弃用,取而代之的是zoneinfo模块及其后端口。因此,即使您像前面建议的那样直接设置时区参数,您可能会面临来自其他地方的相同警告,直到apsheduler将修正pytz在现代Python版本中的用法。
PytzUsageWarning来自于pytz_deprecation_shim包,它是tzlocal的依赖项。Tzlocal与pytz紧密结合。由于apscheduler对tzlocal的依赖相对放松,你可以安装一个相当老的版本,它没有这样的警告,但对于apsscheduler本身来说仍然可以接受。

摘自:https://blog.csdn.net/weixin_43937959/article/details/121765270
————————————————

 

关于博主
北京南城网络及弱电【张工】为您提供:
校园网、楼宇、村镇、园区,光纤网络覆盖,无线覆盖 华为|H3c|锐捷|爱快|panabit等品牌,路由、交换机、AC、AP 无源光网络(PON)设备,布署、调试、维运,等服务...
应急/临时光纤熔接...[藤仓22S]
博文为学习python所写:内容摘自网络、学习笔记、记事备忘。
QQ:872876353,欢迎交流学习、加Q注明来意。

诗文鉴赏

《满江红》· 岳飞
落星侵晓没,
残月半山低。
怒发冲冠,
凭栏处、潇潇雨歇。
抬望眼、仰天长啸,壮怀激烈。
三十功名尘与土,八千里路云和月。
莫等闲、白了少年头,
空悲切。
源于生活-记录日常
The site based on python 3 with flask...